当前位置 : 首页 - ubuntu20无法安装libpq-dev的解决方法

ubuntu20无法安装libpq-dev的解决方法

发布时间:2020年9月18日 15:03 作者:誉新源

ubuntu20无法安装libpq-dev的解决方法:

 

ubuntu下apt-get install安装软件, 报“无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系”。比如以下报错

 

下列软件包有未满足的依赖关系:


 libpq-dev : 依赖: libpq5 (= 12.4-0ubuntu0.20.04.1) 但是 12.4-1.pgdg20.04+1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关

 

 

如果要解决这个问题,那么遵照上面的提示进行安装即可:

sudo apt-get install libpq5=12.4-0ubuntu0.20.04.1
 

安装之后再安装:sudo apt-get install libpq-dev

 

就能成功安装好。

相关文章